CB7Tuner Forums

Go Back   CB7Tuner Forums > Beginner forum -- New members post here! > Beginner Technical/Performance

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-21-2015, 11:17 PM   #1
Trenton_365
Newcomer
 
Join Date: Oct 2014
Location: Mount Vernon, Ohio
Posts: 2
Trenton_365 is cool... so far.
Terrible Oil leak

Hey guys I don't think I have posted on here but I can't seem to find where I'm losing oil from.. I've replaced the oil pan and gasket, and valve cover gasket. There is fresh oil on the back of the motor under the valve cover but above the oil pan. Oil is being sprayed all over the belts. Cam seal? Not so sure
Trenton_365 is offline   Reply With Quote
Old 01-21-2015, 11:40 PM   #2
dj_ender
Mod\Dubstep Pusher
 
Join Date: Jun 2011
Location: Deev's House
Posts: 3,944
dj_ender seems to have made some friends! dj_ender seems to have made some friends!
Either the oil pressure sensor, or the oil filter.
__________________
Quote:
Originally Posted by Mishakol129 View Post
Do not disrespect my intelligence. I am the smartest person I know : )
dj_ender is offline   Reply With Quote
Old 01-22-2015, 08:51 AM   #3
Trenton_365
Newcomer
 
Join Date: Oct 2014
Location: Mount Vernon, Ohio
Posts: 2
Trenton_365 is cool... so far.
I don't that would be it because it's way under where I'm seeing wet new oil.. I'll keep it updated. Maybe a oil filter o-ring? But thanks!
Trenton_365 is offline   Reply With Quote
Old 01-22-2015, 09:18 AM   #4
TransworldCB7
CB7tuner Member
 
Join Date: Jul 2013
Location: Arlington, Texas
Posts: 32
TransworldCB7 is cool... so far.
Oil filter ring is possible if whoever did the last change neglected to double check and make sure it came off along with filter.
TransworldCB7 is offline   Reply With Quote
Old 01-25-2015, 11:47 PM   #5
Guero112
CB7tuner Member
 
Join Date: Feb 2012
Location: Watts, CA ; Tulsa, Ok
Posts: 49
Guero112 is cool... so far.
Most likely oil pressure sensor, its right above oil filter and so it looks like your oil filter is leaking. If not, depending on which model your talking about (i presume its an F series 22a specifically) it may be the the oil cooler found on the f22a6. If you have the F22a1 or a4 then i would bet on the oil sensor.

If you do decide to replace the sensor anyway for S&G's then only hand tighten and please do not over torque it by using tools. I Literally fixed and then rebroke my newly rebuilt f22a4.
Guero112 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.